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 Take Information beyond Excel 

Overview 

Reports produced by XLReporter are stored as Excel workbooks and worksheets.  However, there are many times 

when the entire report or specific information contained within the report needs to be put into a different format or 

application. 

The following roadmap shows all the options XLReporter has available to move report information into different 

formats. 

Publish as a Web Page 

Once the report is generated it can be published as a web page (HTML file) so that it can be viewed using a web 

browser.  The entire workbook or a specific worksheet can be published. 

This is done in the Schedule Designer by adding a new Action. 

 

Under Publish Reports, the Save Workbook to Web Page and Save Worksheet to Web Page actions are available. 

For the Save Workbook to Web Page action, the Workbook setting should be set to the name of the template 

workbook used to generate the report. 

For the Save Worksheet to Web Page action, the Worksheet setting should be set to the name of the template 

workbook and worksheet (period separated) used to generate the report. 

The Workbook and Worksheet settings follow the Report Names settings in the template. 

For both actions, the Target setting is available.  The following options are supported: 

• Blank 

If left blank, the name of the HTML file is based on the Report Names settings of the template.  The file is published 

under a folder for the template within the Web Folder defined in the project.  This can be modified in the Project 

Explorer under the Project tab by selecting Web Page. 
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• Path 

A path may be specified which determines where the HTML file is published.  The path must end with the directory 

separator (\), e.g., C:\temp\. 

The file name is based on the Report Names set in the template. 

• File Name 

A file name may be specified which defines the name of the HTML file published.  The file is published under a 

folder for the template within the Web Folder of the project. 

• Path and File Name 

A full path and file name may be specified which define both where the file is published and what name it is 

published as. 

These actions can be scheduled any time after the report is generated.  For example, if the report is generated every 

day at 12:15 AM, the HTML publishing can also be scheduled at 12:15 AM as well just as long as the HTML publish 

action is listed beneath the generate report action in the Schedule Designer. 

Publish as a Secure PDF 

Once the report is generated it can be published as a secure PDF file.  The entire workbook or a specific worksheet 

can be published. 

This is done in the Schedule Designer by adding a new Action. 

 

Under Publish Reports, the Save Workbook to PDF and Save Worksheet to PDF actions are available. 

For the Save Workbook to PDF action, the Workbook setting should be set to the name of the template workbook 

used to generate the report. 

For the Save Worksheet to PDF action, the Worksheet setting should be set to the name of the template workbook 

and worksheet (period separated) used to generate the report. 

The Workbook and Worksheet settings follow the Report Names settings in the template. 

For both actions, the Target setting is available.  The following options are supported: 

• Blank 

If left blank, the name of the PDF file is based on the Report Names settings of the template.  The file is published 

under a folder for the template within the PDF Folder defined in the project.  This can be modified in the Project 

Explorer under the Project tab by selecting PDF. 



Copyright © SmartSights 2023. All rights reserved. 

• Path 

A path may be specified which determines where the PDF file is published.  The path must end with the directory 

separator (\), e.g., C:\temp\. 

The file name is based on the Report Names set in the template. 

• File Name 

A file name may be specified which defines the name of the PDF file published.  The file is published under a 

folder for the template within the PDF Folder of the project. 

• Path and File Name 

A full path and file name may be specified which define both where the file is published and what name it is 

published as. 

These actions can be scheduled any time after the report is generated.  For example, if the report is generated every 

day at 12:15 AM, the PDF publishing can also be scheduled at 12:15 AM as well just as long as the PDF publish action 

is listed beneath the generate report action in the Schedule Designer. 

Security Settings 
When a PDF file is published, it can adhere to specific security settings.  These can be set in the Project Explorer, 

under the Project tab by selecting PDF. 

 

By checking PDF Access Protection, passwords, Encryption and Permissions can be enabled and disabled.  These 

settings are applied to any PDF file published after they are saved. 

Export to a Relational Database 

Information in a report can be written to a table in a relational database.  This can be quite useful because not only 

can process data brought into the report be exported but also calculated summaries using Excel formulas. 

Database Data Connector 
In order to export data to a database a database data connector must be defined in the project.  This is done from 

the Project Explorer under the Data tab by selecting Connectors. 

New connectors are configured by clicking the Add button. 
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Under Database select a database type and click OK to define. 

 

To define the specific database to use, click the browse pushbutton […], select the Database type on the left and 

specify the specific database on the right. 

Set up/Identify a Database Table 
If the database defined in the connector does not have the table set up to export data to, you can either use the 

tools provided by the database manufacturer (e.g., the Microsoft SQL Server Management Studio or MySQL 

Workbench) or you can use the Database Manager provided by XLReporter. 

The Database Manager is opened from the Project Explorer, under the Tools tab by clicking Manager in the Database 

section. 
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To start, at the top select the database connector defined. 

To add a new table, click the Add button and specify a Table Name. 

Under the Columns section add each column required by specifying the Name and the Type of data to log to that 

column. 

Click OK to create the table. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to a database table, set the Category to Data Export and the Type to To 

Database. 

 

One or more rows of data in the report can be exported as rows in the database table.  The number of rows 

exported is determined based on the Range settings.  The Range can be fixed or can be determined at runtime 

based on the Direction and End settings. 

The Configuration setting defines the entire configuration for the export.  To define, click the browse button […] under 

the Value column. 

 

Specify the Connector to the database and choose the Table to export to. 
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There are two Methods to export data, either based on Columns or Commands.  The Commands method is intended 

for advanced users who have a good working knowledge of SQL.  The Columns method is used to assign columns 

from the selected table to cells on the worksheet. 

 

If the Range encompasses multiple rows, the Cell assigned to the Column is the top cell which will be used for the first 

row of data. 

For example, if the Range is 24 rows and the Cell assigned to the Column is $B$4 then 24 rows of data are exported to 

the database table.  The first row exports the data from $B$4, the second from $B$5, and so on until the last row from 

$B$29. 

Write Values to XLReporter Variables 

XLReporter provides Variables that can be used to hold values that can be used throughout the product.  For 

example, a report may be generated to show the maximum temperature of an oven over the day along with the 

timestamp it occurred.  That timestamp can then be written to a Variable and then used in another history data 

group to report on other process values at the time the maximum occurred. 

There are different Variable types available based on the type of data to store.  The most general Variable is a 

Register which can be used to hold any type of data from numbers to text to timestamps.  There are 100 Register 

Variables available in the project. 

Variable Setup 
Variables are set up in the project in the Project Explorer under the Data tab by clicking Variables. 

 

The available Variable types are listed on the left.  To add a variable, select the next available empty row in the 

middle and click Modify. 
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Here the Name can be customized, and the Description set. 

Once a Variable is configured, when selected the current value(s) are shown on the right.  To change the value, 

click Set Value and specify. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to XLReporter Variables, set the Category to Data Export and the Type to To 

Variables. 

 

Up to four variables can be set with cell values with a single connection by specifying an Input Cell where the data is 

on the worksheet and the Variable to set it to. If more than four variables are required, instead utilize the Data Export, 

To Variable List management function. 
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Write Values to the Process 

XLReporter has the ability to write values back to the process like to a PLC or HMI/SCADA system.  This can be used as 

a handshake mechanism to alert the process that the report is complete or as a way of writing out analytical 

information like the overall equipment efficiency of a piece of machinery so it can be displayed on an HMI display to 

alert operators on current performance. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to tags in the process, set the Category to Data Export and the Type to To Tag 

List. 

 

The Configuration setting defines the entire configuration for the export.  To define, click the browse button […] under 

the Value column. 
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Specify the Connector to the real time process. 

 

Under the Tag List tab specify each Tag to write to along with the Cell to get the value from. 

Text File 

A range on a report worksheet or the entire worksheet itself can be exported as a text file.  This can be very useful in 

applications where the data in the report needs to be fed to another application like ones that can do high level 

analysis. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to a text file, set the Category to Data Export.  There are two options available 

for Type:  Range to Text to export a range from the worksheet to a text file and Worksheet to Text to export an entire 

worksheet to a text file. 
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For Range to Text the Range settings define the range of cells to export to the text file.  This can either be a fixed 

range or can be determined during runtime based on the Direction and End settings. 

The settings at the bottom determine what text file Format to save as, where to store the file, what the name of the 

file is and what to do if the file already exists. 

XML File 

A range on a report worksheet can be exported as an XML file.  This can be very useful in applications where the 

data in the report needs to be fed to another application that requires data in XML format and provides the schema 

of the XML file. 

Define a Schema 
In order for XLReporter to export report data to an XML file an XML schema file must be defined.  This can be done 

with a simple application like Notepad.  There are many examples of XML schemas available on the internet. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to a text file, set the Category to Data Export and Type to Range to XML 

(Schema). 
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The Range settings define the range of cells to export to the XML file.  This can either be a fixed range or can be 

determined during runtime based on the Direction and End settings. 

The settings at the bottom determine the Schema file for the XML file, where to store the file, what the name of the 

file is, the Table within the Schema to use for the data what to do if the file already exists. 

An Excel Workbook 

A range on a report worksheet or the entire worksheet itself can be exported to any other Excel workbook on the 

local machine or across the network.  This can be very useful if there are existing Excel workbooks already used by 

people in the organization who want to add some of the report information to other stuff they have or as a way of 

exporting summary information from one report to another. 

Configure Data Management 
As part of any template data management can be configured which is executed after data connections are 

executed to bring data into the report. 

Data Management is configured in the template by selecting Data, Connect in the Template Design Studio (or from 

the XLReporter menu in Excel).  Once opened, select the Manage tab. 

To export values from the worksheet to another workbook, set the Category to Data Export.  There are two options 

available for Type:  Range to Workbook to export a range from the worksheet and Sheet to Workbook to export an 

entire worksheet. 
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For Range to Worksheet the Range settings define the range of cells to export.  This can either be a fixed range or 

can be determined during runtime based on the Direction and End settings. 

The settings at the bottom determine where the workbook is to export the data to.  For Range to Workbook the other 

settings determine where in the workbook to export the data to.  For Sheet to Workbook the other settings determine 

what to name the exported worksheet in the workbook and what to do if the worksheet already exists. 
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